m.programmer

ارور هنگام اجرا کردن پروژه و بعد از ساختن پروژه در ایکلیپس

6 ارسال در این موضوع قرار دارد

سلام دوستان یه مشکلی داشتم

من مبتدی هستم و تازه میخام برنامه نویسی امدویدو شروع کنم

من وقتی در ایگلیپس یه پروژه جدید ایجاد میکنم بعد از ساخت، چندتا ارور در قسمت Problems نشون میده و وقتی هک که میخام پروژه رو Run کنم ارور میده . 

هیچ کد نویسی هم نمیکنم که بگیم بخاطر اونه. همین اولش تا پروژه رو میسازم این ارور ها میاد لطفا راهنمایی کنین 

عکساش هم گزاشتم:

این عکس هنگام Run کردن:

attachment.php?attachmentid=129566&d=1426686164

اینم ارور های به محض ساختن پروژه:

attachment.php?attachmentid=129567&d=1426686164

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

کد قسمت xml رو عکسش رو بزار شاید بتونم کمکی بکنم.

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

سلام  با توجه به عکسی که گذاشتید و اینکه از appcompat  هم خطا گرفته ممکنه فایلها خوب  load نشده باشند ابتدا روی appcompat  و همچنین سپس روی پروژه خود راست کلیک کنید و refresh رو بزنید اگر خطا ها نرفت یک بار هم Eclipse را ببندید دوباره باز کنید اگر درست نشد به احتمال زیاد مشکل از ADT  است کد XML  هم قرار دهید یه نگاهی بیاندازیم :dodgy:

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

سلام  با توجه به عکسی که گذاشتید و اینکه از appcompat  هم خطا گرفته ممکنه فایلها خوب  load نشده باشند ابتدا روی appcompat  و همچنین سپس روی پروژه خود راست کلیک کنید و refresh رو بزنید اگر خطا ها نرفت یک بار هم Eclipse را ببندید دوباره باز کنید اگر درست نشد به احتمال زیاد مشکل از ADT  است کد XML  هم قرار دهید یه نگاهی بیاندازیم :dodgy:

مرسی از راهنماییت این کارایی که گفتینهم انجام دادم ولی نشد. 

اینم کد:

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

سلام  با توجه به عکسی که گذاشتید و اینکه از appcompat  هم خطا گرفته ممکنه فایلها خوب  load نشده باشند ابتدا روی appcompat  و همچنین سپس روی پروژه خود راست کلیک کنید و refresh رو بزنید اگر خطا ها نرفت یک بار هم Eclipse را ببندید دوباره باز کنید اگر درست نشد به احتمال زیاد مشکل از ADT  است کد XML  هم قرار دهید یه نگاهی بیاندازیم :dodgy:

مرسی از راهنماییت این کارایی که گفتینهم انجام دادم ولی نشد. 

اینم کد:

بنظر شما اگه درست نشد برم با اندروید استودیو کار کنم؟

خب Eclipse قلق های خودشو داره اولین بار که برنامه رو نصب می کنید بهتره یک ریستارت انجام دهید و بعد از اینکه اولین بار برنامه را اجرا می کنید باید صبر کنید به خوبی load  شود الان appcompat  به خوبی load  نشده  و برنامه مثل اینکه پیداش نکرده فایل های داخل workspace  را جابجا نکردید که؟ یه سری به پوشه worksapce بزنید ببینید پوشه appcompat  موجود است؟ پیشنهاد من اینه ADT را دوباره نصب کنید

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

شما یک پروژه جدید که بسازی و اگر ورژن اندروید پایین باشه ، بخوای از اکشن بار و ... استفاده کنی یکدونه دیگه از همینا میسازه!!!

بعد روی پروژه ای که به این کتابخوانه نیازمنده کلیک راست میکنی !! گزینه پروپرتیس و بعدش android رو انتخاب میکنی  !! پایین صفحه به کتابخونه نیاز داره که احتمال علامت قرمز خورده !! پاکش میکنه و گزینه اد رو میزنی !! جدیدرو به عنوان کتابخونه انتخاب میکنی !! درست میشه !!

موفق باشی

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری