mbpourya

رفع ابهام ایجاد پروژه

3 ارسال در این موضوع قرار دارد

سلام

استادای عزیز بنده چند وقته دارم برنامه نویسی با اکلیپس رو دنبال میکنم اما یه مشکلی که از همون اول باهاش داشتم و دارم این سه گزینه هست:

1-Minimum Required SDK

2- Target SDK

3- Compile With

گزینه اول و دوم رو درک کردم اما هیچ جا در مورد سومی توضیحی پیدا نکردم! :S

دقیقا اگه من بخوام برنامم روی تمامی نسخه های اندروید 2.2 به بعد اجرا بشه اینارو باید چجوری قرار بدم؟ :huh:

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

گزینه سوم برای کامپایل کردن پروژه، در زمان توسعه اون هست. به عنوان مثال وقتی که شما اونو روی api19 ست کنید، پروژه شما موقع تست روی api19 کامپایل و اجرا میشه اما این گزینه هیچ ارتباطی با minimum sdk (کم ترین مقدار sdk) و target sdk (بیشترین مقدار sdk)نداره. اگه می خوای پروژه ای بنویسی که روی اندروید 2.2 به بالا اجرا بشه باید minimum sdk رو روی api8 و target sdk رو روی api21 (اندروید 5) قرار بدی که آخرین ورژن اندروید هستش.

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

گزینه سوم برای کامپایل کردن پروژه، در زمان توسعه اون هست. به عنوان مثال وقتی که شما اونو روی api19 ست کنید، پروژه شما موقع تست روی api19 کامپایل و اجرا میشه اما این گزینه هیچ ارتباطی با minimum sdk (کم ترین مقدار sdk) و target sdk (بیشترین مقدار sdk)نداره. اگه می خوای پروژه ای بنویسی که روی اندروید 2.2 به بالا اجرا بشه باید minimum sdk رو روی api8 و target sdk رو روی api21 (اندروید 5) قرار بدی که آخرین ورژن اندروید هستش.

مچکرم از توضیح کامل و وقتتون

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری