javady_joon

api چیست؟

10 ارسال در این موضوع قرار دارد

سلام دوستان من به یک مشکلی بر خوردم در واقع دارم از روی یه کتابی اندروید کار می کنم ولی نمی دونم چرا اینقدر به  Warning

بر می خورم یکی از دوستان گفت api ات رو عوض کن ولی من متوجه منظورش نشدم میشه بیشتر توضیح بدین که چطور تغییرش بدم؟

و یکی از دوستان می گفت با وجود Warning می تونی برنامه ات رو اجرا کنی در حالی که شبیه ساز من با وجود Warning برنامه رو کامپایل نمی کنه و فایل apk. رو ایجاد نمی کنه. می خوام بدونم چطور میشه با وجود Warning برنامه رو کامپایل کرد و فایل apk. رو تولید کرد؟

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

api همون sdk هست

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

سلام

اخطار ربطی به اجرا نداره ! من تا به حال به چنین چیزی برخورد نکردم ! API هم ربطی این چیزها نداره !

API = application programming interface

َُُSDK =Software Development kit

این دو از هم خیلی جدا هستند !! اگر API همون SDK هست پس چرا 2 تا اسم ؟

ََAPI یک سری رابط بین برنامه نویس و برنامه است که یک سری برنامه های خاص رو با استفاده از همینها طراحی کنند !

معمولا هم به API شماره های اندروید رو میگند که مثلا API 22 اندروید 5 هست .

SDK یک سری بسته ی نرم افزاری است که اصلا اگر نباشه برنامه ای نخواهد بود که API داخلش اجرا بشه !

به هر حال خواستم کمی اطلاعات عمومیتون رو بالا ببرم :)

اما اصلا سوال شما کلا ربطی نداره !

موفق  باشید

SDK همون API هست ، API کتابخانه ای از کلاسهاست که برنامه نویس میتونه از اونها تو برنامه ش استفاده کنه ، حالا یک ابزار اضافی مثل دیباگر داخلی و ... به همین API ها اضافه کردن و اون رو به شکل یک کیت یا بسته در آوردن ، زیاد به نام ها توجه نکنید ، گوگل میگه SDK و مایکروسافت میگه Framework ، ولی هر دو یه کار انجام میدن ، از این کتابخونه ها زیاد داریم

.net مایکروسافت

J2EE و J2SE شرکت Sun

SDK اندروید گوگل

SDK اپل

و ...

ً

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

باشه آقا شما زیاد بلدی

ولمون کن ! اصلا تو درست میگی !

یا حق

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

دوستان خوبم چرا دعوا می کنید کمکم کنید


آقا چرا ربطی نداره آخه

من پرسیدمن که Api رو چطور عوض کنم؟ من با ایکلیپس کار می کنم و به این مشکل برخوردم

u8eq_2-1.jpg

لین هم خطاش

55he_3.jpg

آقا کمکم کنید جای دوری نمیره بذارید من هم برنامه نویسی اندروید رو خوب یاد بگیرم

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

سلام

بینید دوست عزیز من

هر تم مربوط به نسخه های متفاوته اندروید هست

یعنی الان شما اندروید 2.2 رو انتخاب کردید که ipa ان 8 هستش

پس اگر شما بخواید تم برنامتون رو تغییر بدید و بروز کنید میباست نسخه اندروید خودتون هم تغییر بدین

برای برخورد نکردن به این خطا ها کافیه از کتابخونه appcompat-v7 استفاده کنید

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

خوب میشه بگید چطور باید از کتابخانه استفاده کنم؟

من مبتدی ام


اگر از اندروید استیدیو استفاده کنم چطور؟

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

خوب میشه بگید چطور باید از کتابخانه استفاده کنم؟

من مبتدی ام


اگر از اندروید استیدیو استفاده کنم چطور؟

اگر میخواید تازه شروع کنید بهتر است با اندروید استدیو اندروید رو یاد بگیرید تا اکلیپس !

نحوه ایمپورت کردن کتابخانه در اکلیپس:

مسیر کتابخونه ذکرشده در sdk\extras\android\support\v7\appcompat

http://www.appance.com/add-appcompat-v21-material/

1 کاربر پسند دیده است

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

ممنون از اندروید استیدیو سایت میشه استفاده کرد؟

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری