جواد زبیدی زاده

آموزش ایجاد پرداخت درون برنامه ای به وسیله زرین پال

5 ارسال در این موضوع قرار دارد

با سلام

زرین پال اومده کتاب خانه ای ایجاد کرده که میشه به راحتی بدون نوشتن  کد های سمت سرور درون برنامه یک درون پرداختی ایجاد کرد که  میشه خود برنامه نویس امنیتش  رو تامیین کنه خب من هم اومدم آموزش ویدئوی  این  کتاب خانه رو ظبط   کرد که برای شما قرار میدم

آقای سرسیفی   من برای اینکه به زرین پال بفرستم  توی پیکو فایل آپلود  کردم  اگر میشه خودتون توی سایت ارسال  کنید و اتچ کنید سپاس :)

 

دانلود از سرور انجمن اندروید ایران

zarinpalpayment.mp4

 

 

لینک کمکی :

لینک دانلود

 

 

 

 

2 کاربر پسند شده است

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

سلام و خسته نباشید

سوال اول:

بنده برای یک سایت میخوام درگاه زرین پال را بر روی اندروید ایجاد کنم

توی اون سایت درگاه فعال هستش

حالا من میخواستم بدونم اگر فقط ادرس محصول را بدونم مثل

https://zarinp.al/9999

ایا نمیتونم خودم این درگاه را بالا بیارم؟

سوال دوم:

میخواستم بدون گرفتن مرچنت ای دی این کار را انجام بدم

اگر ما درخوست را به سرور سایت بفرستیم ایا اونها نمیتونن به عنوان پل واسط عمل کرده و اطلاعات را بین اندروید و زرین پال تبادل کنند؟

برای حفظ امنیت مرچنت ای دی و ای پی سرور سایت

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

سوال سوم: 

با استفاده از ویدیو اموزشی زرین پال را در اندروید استودیو اماده کردم موقع خروجی گرفتن خطای زیر را میدهد:

Error:Execution failed for task ':app:processDebugManifest'.
> Manifest merger failed : uses-sdk:minSdkVersion 9 cannot be smaller than version 14 declared in library [com.zarinpal:purchase:0.0.3-beta] D:\Hamdardy\app\build\intermediates\exploded-aar\com.zarinpal\purchase\0.0.3-beta\AndroidManifest.xml
    Suggestion: use tools:overrideLibrary="com.zarinpal.ewallets.purchase" to force usage

چیزی که من ازش فهمیدم:

کتابخانه زرین پال با sdk 14 نوشته شده در حالی که برنامم  را با کمترین sdk  را 9 در نظر گرفتم چجوری کد بزنم 
چجوری بهش بگم تو از گوشیهای با sdk 14 به بالا اجرا بکن و مثلا برای پایین تر از 14 یه پیام نشون بده

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
در 3 ساعت قبل، jef313 گفته است :

سوال سوم: 

با استفاده از ویدیو اموزشی زرین پال را در اندروید استودیو اماده کردم موقع خروجی گرفتن خطای زیر را میدهد:

Error:Execution failed for task ':app:processDebugManifest'.
> Manifest merger failed : uses-sdk:minSdkVersion 9 cannot be smaller than version 14 declared in library [com.zarinpal:purchase:0.0.3-beta] D:\Hamdardy\app\build\intermediates\exploded-aar\com.zarinpal\purchase\0.0.3-beta\AndroidManifest.xml
    Suggestion: use tools:overrideLibrary="com.zarinpal.ewallets.purchase" to force usage

چیزی که من ازش فهمیدم:

کتابخانه زرین پال با sdk 14 نوشته شده در حالی که برنامم  را با کمترین sdk  را 9 در نظر گرفتم چجوری کد بزنم 
چجوری بهش بگم تو از گوشیهای با sdk 14 به بالا اجرا بکن و مثلا برای پایین تر از 14 یه پیام نشون بده

سلام

شما میتونید به صورت سایت کد بزنید ولی این هم توصیه نمیشه بهتره  که  ارتقا بدید اس دی کی رو

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

تشکر اقا جواد

لطفا به سوال اول و دوم بنده پاسخ بدبد

با تشکر

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری