armin sf

مشکل درباره ی نصب sdk اندروید...!!!!!!!!

13 ارسال در این موضوع قرار دارد

با سلام خدمت کاربران و مدیران محترم 

سوالاتی دارم که اگه این سوالات و مشکلاتم و حل کنید واقعا یه دنیا ممنون میشم 

من تمام کارهایی که به گزینه run برای نصب اندروید بر روی رایانه انجام داده ام 

من میخوام api های اندروید 2.3.3 رو از طریق بسته sdk منیجر دانلود کنم ولی نمیدونم تو تمام این بسته ها کدومش برای نصب کامل sdk نیازه البته api اندروید و نصفش و دانلود کردم ولی نمیدونم به جز این بسته ها چه بسته ی دیگری باید از درون sdk منیجر دانلود کنم 

و این بسته هایی که دانلود میشه به صورت خودکار نصب میشه یا نه باید به مکانی در کامپیوتر رفت تا این بسته هارو نصب 

کنیم ؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟

تصویر زیر و که مشاهده میکنید من api اندروید و میخوام به طور کامل دانلود کنم ولی بعد از دانلود چیکار کنم 

ml9n4200519qtno5bw1c.jpg

yh7xjh2wa9tcoq50cv1g.jpg

by6zphd5aqw7b6kuzfbt.jpg

دو تصویر اخری من باید دقیقا کدومشون و نصب کنم ؟؟؟؟؟؟؟؟؟؟؟؟؟

و هم چنین من بسته ی android sdk build-tools هم دانلود کردم

واقعا ممنون میشم این مشکل بزرگ منو حل کنید و بهم بگید با تشکر فراوان ;);););)

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

شما برای داشتن api های مختلف  فقط  باید sdk platform ها را دانلود کنید.

به android sdk tools , android sdk platform-tools هم نیاز دارید.

usb driver نیز نیاز است.

support library  را هم.

بقیه بسته ها نیز به فراخور پروژه باید نصب کنید.اگر نیاز داشتید.

در ضمن این بسته ها خودشان نصب می شوند و نیاز به انجام کاری نیست.

در واقع یک سری فایل زیپ هستند که دانلود می شوند و سپس در مسیر sdk آنزیپ می شوند

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

من بعد از نصب تمام این مواردی که گفتید برای اینکه در اکلیپس اندروید و api ها وارد این نرم افزار بشوند چه کاری باید بکنم یا اینکه دوباره به صورت خودکار در نرم افزار اکلیپس نصب میشوند ؟؟؟؟؟؟؟؟؟؟؟؟

من فقط از زیر مجموعه های api های اندروید 2.3.3 باید sdk platfrom و نصب کنم یعنی نیازی به samples for sdk و... نیست ؟؟؟؟؟؟؟؟؟

گوگل لایبرری و یو اس بی درایور برای ما چه کاری انجام میدهند ؟؟؟؟؟؟؟؟؟؟؟؟

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

اگر تازه کار هستید بهتر است از adt bundle  استفاده کنید.

اما در مورد سواتان رد دوباره پست قبلی ام را بخوانید.برای دیدن این که چه sdk هایی نصب شده اند می توانید به مسیر window>prefrences>android 

مراجعه کنید.سمپل ها مثال هایی است که اگر مشتاق هستید می توانید دانلود کنید و استفاده کنید.من حداقل ها را گفتم.

برای usb driver هم می توانید به آدرس زیر مراجعه کنید:

usb diver

ساپورت لایبرری هم 

android support library

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

من الان به مکانی که گفتید در ویندوز رفتم ولی پوشه ای با نام prefrences پیدا نکردم الان چیکار کنم ؟؟؟؟؟؟؟؟؟؟

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

دوست عزیز در اکلیپس در تب window.

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

داداش اصلا نه تو اکلیپس و نه تو پوشه ویندروز در مای کامپیوترم نیستش هیچ جا وجود نداره


داداش شما تو خود برنامه اکلیپس و میگی یا پوشه هاشو ؟؟؟؟؟؟؟


داداش اصلا نه تو اکلیپس و نه تو پوشه ویندروز در مای کامپیوترم نیستش هیچ جا وجود نداره


داداش شما تو خود برنامه اکلیپس و میگی یا پوشه هاشو ؟؟؟؟؟؟؟

پیدا کردم داداش یه پنجره باز شد

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

داداش الان همه چیو دانلود کردم برای راهندازی sdk بر روی اکلیپس چیکار کنم ؟؟؟؟؟؟؟؟؟؟؟

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

شما باید با آموزش های شروع با اندروید که در انجمن هست شروع به برنامه نویسی کنید

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

داداش سلام 

من تمام مراحل نصب sdk و تموم کردم میخوام پروژه جدید باز کنم میگه اندروید sdk شما به اپدیت جدید نیاز دار 

میخواستم بدونم اگه اپدیت کنم نیازی به نصب دوباره ی بسته هایی که از sdk دانلود کردم که نیست ؟؟؟؟؟؟؟؟؟؟؟؟

کجا باید اپدیتش کنم ؟؟؟؟؟؟؟؟؟؟؟؟؟؟

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

داداش سلام 

من تمام مراحل نصب sdk و تموم کردم میخوام پروژه جدید باز کنم میگه اندروید sdk شما به اپدیت جدید نیاز دار 

میخواستم بدونم اگه اپدیت کنم نیازی به نصب دوباره ی بسته هایی که از sdk دانلود کردم که نیست ؟؟؟؟؟؟؟؟؟؟؟؟

کجا باید اپدیتش کنم ؟؟؟؟؟؟؟؟؟؟؟؟؟؟

help>check for updates

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

داداش اینو میزنه : The tools need to be updated via the SDK Manager

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

سلام

من اندروید استودیو رو فقط باز می کنم صفحه که بالا میاد این ارور میده :

Error:(23, 13) Failed to resolve: com.android.support:appcompat-v7:21.+

install Repository and sync project

من فکر کنم مربوط به sdk میشه . فکر کنم باید کتابخانه android support Repository رو نصب کنم منتها نمی دونم چطور نصب کنم میخوام فایلش هم دانلود کنم ناقص میا د

ممنون میشم راهنمایی کنید

به اشتراک گذاری این پست


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

برای ارسال نظر یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید نظر ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در انجمن ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری